I need to refer to the attribute of a button that describes whether it is enabled or disabled. "Enablement state" sounds awkward and clunky.
-
2If you put your question into sentence format, then it'll be easier to answer, e.g., "# 5 is the Enable/Disable button" or "Button 5 enables/disables the XYZ function".– user21497Commented Nov 29, 2012 at 21:58
-
5What is wrong with just state? The state of the button is "enabled". The state of the button is "disabled". Perfectly fine. Only not an option if you reserve or already use state for some other attribute of the button, but I struggle to think which attribute that could be.– RegDwigнtCommented Nov 29, 2012 at 22:19
-
1@Cody: again, the word for the "state" of color is Color. The word for the "state" of text is Text, or Label. And so on. "The state of the button is blue"? Nah. The color of the button is blue. "The state of the button is 'On/off'"? Come on. That makes you sound like a non-native speaker. And the word for the superset of all these attributes is not state, either, but attributes, which is why you keep using that word yourself in the first place. I'm afraid you're overthinking this, trying to take problems into account that do not really exist.– RegDwigнtCommented Nov 30, 2012 at 9:49
-
1@RegDwigнt "What is wrong with just state?" There can be a lot of different states: the button can be either in a pressed or a released state, it can also be in either a greyed out state: won't react to when you click on it, or it can be in a functioning state: will react and be pressed when you click on it. Here are just 2 examples of just calling one of them state. What are you going to call the other one then? The thing in programming is that you simply won't be able to refer to both of those things by just using the "state" word.– KulaGGinCommented Oct 15, 2022 at 7:38
-
1The development environment simply won't allow us to have 2 variables with the same "state" name, we have to differentiate.– KulaGGinCommented Oct 15, 2022 at 7:38
5 Answers
I take it you mean a word for whether or not a button is "grayed out", not for whether it has turned something "on" or "off". If "state" or "mode" are too general or in use, then I suggest availability, which could have values "enabled" and "disabled".
It's not whether the button is enabled vs disabled, only that it is disabled or not. Hence the parameter that controls this behavior, in various software and html/css, is simply "disabled", which has a value true or false. It's also more handy in programming logic to treat a bi-state parameter in this way. Instead of all such parameters having all sorts of values you have to keep track of and compare as strings in conditionals. When you name and use a parameter as representing the truth or falsehood of only one of the states, then you can always test more quickly for true or false. Less typos and most programming languages provide shortcut conditionals, e.g. If(button.disabled) instead of if(button.state==disabled).
-
1That's valid, but my issue with this is that it's ambiguous whether the status is enabled:true or disabled:false. I generally prefer to pick the positive term, but I was wondering if there were a way to avoid making that choice altogether.– CodyCommented Nov 30, 2012 at 0:44
-
-
@Cody Yes. Technically the "is" prefix is syntatic sugar. Same idea is there that we were taught many moons ago as good software engineering practise.– ChrisCommented Nov 30, 2012 at 6:01
-
As an additional example from life, one would ask if the light switch is on, instead of asking about the state of the switch in relation to artificial lighting level in the room. Speaking and coding this way makes things simpler, without having an artificial level of semantics on top. In coding, you can easily loop through a collection of say buttons and check which are enabled with a isEnabled flag true. Otherwise you'd potentially have to check each funkily named enablement state property value individually. Come to think of it, the latter confusion is how most microsoft stuff is set up.– ChrisCommented Nov 30, 2012 at 6:13
I think "Enablement state" is as close as you can get.
Cody is looking for a noun to describe the variable that will contain either "enabled" or "disabled", not an adjective that describes its current state. ie. If presence means "the state of being present", then _____ means "the state of being enabled"
As others have suggested, the variable would be named "isEnabled" in code, but this is the English Language & Usage Stack Exchange and isEnabled isn't English. I don't think isEnabled has a direct counterpart in English, and "device is enabled" isn't a noun.
I'm writing a list in plain-english of different settings that can be set for a device. The term that our team chose seems to be "state of operation", but that is ambiguous because without context, it's not clear if the contents of that variable tells us if it's currently operating or whether it's meant to be operating. It is also vague as to what part of the device is enabled.
With "enablement state", it's clearer that it's describing the variable rather than the contents, and as a bonus it's possible to be more specific as to what is being enabled, such as "water enablement state" or "lantern enablement state". That said awkward and clunky are definitely the first two words that come to mind for this phrase.
I think the answer lies in what are you disabling and enabling. The graphic of a toggle button is a verb in and of itself. If it has a label such as "water", you press the button in and as long as the button is in its inward state (or locked down), it's understood that water will continue to flow. As soon as you press the button again to return it to its outward state (or up), it's understood that the water will stop flowing. We already know the button is enabling or disabling something. What is it enabling and disabling?
-
Oh, you're not talking about the label of the button, but the enabled state. My typical approach here is to have the state be a boolean value, and name the attribute the positive form of the state. I.e., if Button.enabled=true, then we know the button is enabled. If Button.enabled=false, then we know the button is disabled. Don't use disabled=true, though since double negatives can be confusing to others. Commented Nov 29, 2012 at 23:07
One of my favorite synonyms to the enabled/disabled pair is the on/off pair. When looking up synonyms for "off" on thesaurus.com, one of its antonyms I found was "present" in the context of being absent/present.
These proved to be helpful, because there are words for the state of being present and the state of being absent (according to dictionary.com). They are "presence" and "absence" respectively. Which one you choose to use depends on what state of being you prefer as a default.
"what state of being you prefer as a default" basically means which state of being is more important to you and stands out?
Example 1:
In schools, absence is considered to significantly take away from your education, so addressing absence is more important to school teachers and admins than your actual presence.
Example 2:
In a program, a new feature's presence is considered more important than its absence. You don't ever want to state that a feature is or could be absent in a program. That's just (simply put) bad marketing.
Example 3:
Another example in programming that is the opposite of the previous example is bugs and their presence in a program. It is more important that bugs are absent than they are present.