20

I'm speaking of the noun having to do with an interval of time.

I need this for programming purposes and it appears some people use "time span" and others "timespan" so I assume both are correct.

2
  • 1
    Haha I went with the word "interval" instead as that is the preferred word in Java.
    – Adam Gent
    Jul 17, 2012 at 20:17
  • Related.
    – tchrist
    Feb 24 at 21:16

5 Answers 5

14

Merriam-Webster doesn't have an entry for timespan. Time span is correct, as you are referring to a span of time. I could see the argument for both being correct, though, as many other "Y of X" are converted into single word XY in english.

For programmers, timespan is used because spaces are not allowed in many places. If you are speaking to programers, timespan will be understood.

10

NGram shows that time span is used far more.

enter image description here

1
  • 3
    Yes, but a significant proportion of the two-word instances are in fact hyphenated - a standard intermediate step when a word-pair is heading for single-word status. Personally, I'd normally have written it as two words 30 years ago. But today I'd always write it as one word (as with timeframe). Jul 17, 2012 at 21:16
5

In "New Oxford Dictionary for Writers and Editors" I read (p. 386):

"time span", two words.

1

Timespan is a word, but you're most likely talking to people who are used to the System.Timespan stucture or something similar.

0

According to this online thesaurus, both "time span" and "timespan" are legitimate and have the identical definition. In using camelCase for variable names, I am not sure if "timeSpan" or "timespan" is the most appropriate for a variable name.

Based on the URL shared in the previous post referring to System.Timer, Microsoft has adopted "TimeSpan" for its related struct naming. I believe the convention for capitalization is that classes and structs begin with a capital letter, but in contrast instantiations of classes begin with a lowercase letter.

Based on Microsoft's adopted spelling and capitalization of its struct "TimeSpan", I assume that it is preferable to name the variable in question "timeSpan" instead of "timespan" amongst the two options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.