I'm making a game in which the player can either push or drag certain objects, like crates.
In my code I usually refer to both of these actions as "moving" whenever I don't want to specify which one I'm talking about (for instance, if I need to write a function that checks whether an object is being pulled or dragged I'll call it is_object_being_moved).
There are, however, other reasons why an object might move other than the player pushing or dragging them, so I'd like to substitute all those instances of "move" for something more specific.
I thought about "lug", but it means "dragging or carrying" rather than "dragging or pushing". "Displace" or "transport" are still too general. "Budge" is more of a one-time burst of movement.
So can any of you think of a word that means both "to push" and "to drag"?