I am trying to find a name for a variable that contains the hostname (node45.service.com), the port (9984) and the server name (US Salami Server) of a service I want to connect to and looks something like this
class server_connection_configuration string server_name string hostname integer port
At the moment it's called server_connection_configuration. Is there a shorter alternative for that? It must encompass that it is a set of parameters that are needed to connect to a server. I understand that the server name does not really fit here.
I can't use server_connection because this implies that this would be the object that models the connection (a handle). I also can't use connection_configuration because in that context other connections exist as well.
I don't want to use abbreviations because it would contradict clean code principles.
What word(s) could I use instead?
single-word-requests but maybe there is a better tag for this question.