I'm currently designing a software library. There are only two hard problems in computer science: Naming things, Cache invalidation and off-by-one errors.
And at the moment I'm struggling with problem 0: Naming things. The whole thing is for a data collection device. Before the device is started one sets a number of records that shall be collected. While the device is running it can be polled for the number of records obtained so far, or – if a timeout was reached or the process aborted – how many records there are in total.
Now the question is, what (single) words to use for denoting "this is the number of records that shall be taken" and what word for "this is the number of records we have"?