5

In a software program we have a function which asserts if the current date is a working day, and if it's not it retrieves the next working day.

Currently the function is called getNextWorkingDay(DATE)

When using the function in the following manner getNextWorkingDay(*saturday*) would return Monday (unless Monday is a holiday).

My problem with this name is, if you call this function with a working day as a parameter, it does not return the next day, but the given day. So a better name would be assertIfWorkingDayOrGetNextWorkingDay which is a bit on the long side.

Q: Is there a hypernym for "current or next" which I could use like this: getHypernymWorkingDay

  • 1
    I would suggest just getAvailableWorkingDay. This question is so close to the off-topic line it's in grave danger of crossing it. You could call your function Margaret and it would work just as well. Here's an example of an on-topic naming question – Andrew Leach Nov 28 '16 at 10:43
  • This question may be a good fit for StackOverflow. – WillB3 Nov 28 '16 at 17:25
  • @Andrew Leach not disagreeing this is off-topic, but that linked question is also closed as OT. (Though IMO what to call a non-empty set is interesting) – anotherdave Nov 28 '16 at 21:07
  • I think that, even through there is a programming context provided as background for the question, this question and the answers refer to the on-topic title in a productive way. As a question of Java style, getCurrentOrNearestWorkingDay might actually be preferred! But that isn't the question before ELU -- instead, the question is, given this naming strategy / attempt, does a concise term or phrase for the current-or-next exist? That's ELU. – JeremyDouglass Nov 28 '16 at 21:15
  • 1
    @anotherdave The other question gained all of its upvotes after the edit, which wasn't soon enough to counteract the close votes it had already attracted. The edited question is on-topic, but It's Not The Done Thing for me to re-open it unilaterally. – Andrew Leach Nov 29 '16 at 0:17
5

Effective may be an effective hypernym for your purpose.
Effective date is typically used in business contexts to signify a date when something comes into effect. In your context, effective would mean current or (if current is not applicable) next (business day).
For example, if you give your bank an instruction (electronically or otherwise) during non-business hours (like on a Saturday or sometimes even after business hours on a working day), usually they are not bound to execute it until the nearest available business hours, typically due to "operational" reasons. (There may be exceptions to this.)
Also, usually in such contexts, the accounting entry will have the date of the next working day.

Wikipedia:

An effective date or as of date is the date upon which something is considered to take effect, which may be a past, present or future date. This may be different from the date upon which the event actually occurs or is recorded.

  • very good suggestion! – NDM Nov 29 '16 at 15:10
4

Suggestion 1. just: get the working day, getWorkingDay.

On Friday, this is Friday. On Saturday, this is Monday.

In many English language situations, the way to specify "the current or next" is to specify nothing; use the or a bare subject.

So: "get the newspaper" -- get the currently available or next available newspaper, whether already at-hand or from a newsstand.

Suggestion 2: If "getWorkingDay" seems potentially ambiguous (perhaps the working day is "None"?), use a proximity word like 'nearest' or 'closest' which will always include the current day if appropriate:

getNearestWorkingDay()
getClosestWorkingDay()
getProximalWorkingDay()
0

I know that you're looking for a get____WorkingDay structure, but considering how obscure the ____ would be for that (assuming one exists,) I suggest using 'getNextWorkingDayInclusive' instead, a get____WorkingDay_____ structure.

definition of 'inclusive' from dictionary.com

including or encompassing the stated limit or extremes in consideration or account (usually used postpositively):

I believe that 'getNextWorkingDayInclusive', conveys the meaning that "if you call this function with a working day as parameter, it does not return the next day, but the given day"

  • I'm afraid this answer has fallen into the trap of answering the naming question (which is off-topic) instead of the "what is the word?" question (which is on-topic). You might be able to get away with a simple edit so that you are not suggesting a function name, but the word which should go in the blank. – Andrew Leach Nov 29 '16 at 9:50
  • I don't believe that the accepted answer for get___WorkingDay will be commonly understood, nor do I believe that there is a good one-word solution. I use two words, but since inclusive is used postpositively, it goes at the end of the word, which may obscure the connection. The core question is "is there a hypernym for "current or next" which I could use like this: getHypernymWorkingDay", to which my core answer is "no, but perhaps these two words would work" – Jeutnarg Nov 29 '16 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.