I'm searching for a different or more neutral term than "dummy" to describe a non-functional or non-interactive part of a program.

I've been using this term to refer to code in interactive charts and data visualizations that has no meaningful value, but helps render visual effects that would be hard or cumbersome to create using outside code or more complex methods.

For example, if one series in my chart is just there to add a set of arrow-shaped markers, I've been calling it a "dummy series" (always in quotes).

The third definition of "dummy" on Wiktionary (https://simple.m.wiktionary.org/wiki/dummy) seems to agree with my usage ...

A dummy is something that is not there but people act like its there for some purpose.

... but I'm not 100% comfortable using "dummy" due to its alternate meaning of "stupid" or "unintelligent."

Thank you in advance for your suggestions.

  • 2
    I've provided an answer, but FWIW, as a programmer myself, I don't know if I would call that code inert or a dummy series. It sounds useful to me. Dummy code, in my mind, is code that will never be executed. It has no purpose. This at least serves some function, even if the user doesn't see it. – Athena Jul 16 '16 at 3:42
  • 1
    @Ares- That's not dummy code, that's dead code. dummy things usually stand in place of real things, often during an interim period before the real thing is available. @ Mike- I think your usage is fine and you should not be concerned that the word has other meanings. When you execute your program you (hopefully) aren't concerned that execute can also mean put to death. The context makes it clear which definition is being used. – Jim Jul 16 '16 at 4:03
  • @Jim Thank you for your thoughts and insight. Your "execute" example is truly helpful in showing correct intent when in context. One thing I will note is the "dummy series" I cited are part of the final product and not a stand-in or placeholder in an interim status. – Mike Zavarello Jul 16 '16 at 11:58
  • Why would you want to have non-functional code? That makes no sense to me. – dangph Jul 16 '16 at 13:05
  • @dangph You're correct; what I'm describing does indeed have a function, despite its non-interactivity, so that was a misstatement on my part. Thanks for noting that. – Mike Zavarello Jul 18 '16 at 12:12

The terms ancillary, auxiliary, or supplementary should work better.

Ancillary: providing something additional to a main part or function

Auxiliary: available to provide extra help, power, etc., when it is needed

supplementary: Completing or enhancing something

You can also simply say nonessential:

not completely necessary : not essential

| improve this answer | |
  • I'm grateful for your suggestions, alwayslearning. I do like "ancillary," but I'm curious how widely understood that term might be. I would argue that "nonessential" isn't quite a good fit, since the "dummy series" are "essential" to provide the non-interactive visual effects. – Mike Zavarello Jul 16 '16 at 11:39
  • 1
    @MikeZavarello, in that case, the more commonly used supplementary is your friend. Although I indirectly mentioned it (as a synonym of ancillary) in my answer earlier, I have now also included definition and ODO link. – alwayslearning Jul 16 '16 at 11:51
  • "Supplementary" reads the best to me. Thank you for updating your answer with that suggestion, and for your guidance overall. – Mike Zavarello Jul 18 '16 at 12:13

One term that is often used in programming is stub.

That is "filler" for a portion of the program that is not yet written.

| improve this answer | |
  • 1
    This is not what the OP wants. The code mentioned is not filler but somewhat nonessential. They are not the same. – alwayslearning Jul 16 '16 at 9:02
  • Thanks for your suggestion, Tom. @alwayslearning is correct: I'm not referring to a placeholder or filler, but part of a finished product that isn't "true" data or an interactive piece. – Mike Zavarello Jul 16 '16 at 11:34
  • @MikeZavarello: The "filler could be made a "non-functional or non-interactive part of a program." A "stub" usually has a minor function, but it doesn't have to. That is to say,a stub could be so that "one series in my chart is just there to add a set of arrow-shaped markers," – Tom Au Jul 16 '16 at 13:42

I'm a fan of "inert."

It's definition isn't 100 percent literal:

From Dictionary.com:


having no inherent power of action, motion, or resistance (opposed to active)

| improve this answer | |
  • "Inert" is a good suggestion, Ares; thank you. It implies non-interactivity and yet something that's present and can be observed. – Mike Zavarello Jul 16 '16 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.