-1

The majority of components in a computer program I'm currently developing are allowed to "present" themselves to an external entity through a given medium (e.g., to a user through a pre-defined UI glyphs).

Whenever I ask them to do so, I will invoke the following command:

show(Medium)

A subset of said components, however, have slightly more privilege: not only that they are allowed to present themselves, they are also given the power to listen to interactions in the form of events and/or requests made, again, by an external entity.

As of this moment, the command looks like the following:

showAndListen(InteractiveMedium)

But I find that command to be rather clunky and in the need of a better name.

Is there any single word alternatives to showAndListen?

  • 1
    Off-topic: naming. – Scott Apr 18 '16 at 4:56
  • I'm voting to close this question as off-topic because naming requests are specifically so. – AmE speaker Jan 12 at 14:27
-1

I've never seen this word used, but there's a term called 'transput', which is both input and output together.

Though I would do something like

command_O()

and

command_IO( )

for distinguishing input/output.

-1

I would named the command Avail.

In other words, the component is making itself available, both in the sense of appearance and being able to respond to the external entity's requests.

-1

Your question contains its own answer:

interact(…)

A more jargony option is

interface(…)

but that doesn't clearly imply a bi-directional data flow. 

A more conversational (less jargony) option, which has fewer syllables, is

converse(…)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.