For some context, I'm a programmer looking for a good word to use to label a generic class of things that are all pieces of information that are "fetched" from somewhere. These pieces of information may be fetched more than once.

Up to this point, I've simply referred to the chunk of retrieved information as a "Fetch", but there is confusion in the code since this also refers to action of retrieving the information.

  • 3
    Sorry, but I just had to post this here. youtube.com/watch?v=Pubd-spHN-0
    – Catija
    Jun 25, 2015 at 20:29
  • When I needed a "generic" word for data being fetched or carried somewhere in a computing context, I often used to call it cargo. Jun 25, 2015 at 20:46
  • 2
    If you had an interface class fetchable then all your things would implement fetchable. You wouldn't need to talk about a chunk of retrieved information except internal to fetchable. at that point you might just refer to it as a blob
    – Jim
    Jun 25, 2015 at 20:47
  • 1
    Is there ever a piece of information that is not fetched from somewhere? Even values assigned to a local variable are "fetched" from that variable when they need to be used. The "fetch" is the act of retrieving, not the datum that is fetched.
    – TimR
    Jun 26, 2015 at 0:11

2 Answers 2


As a programmer, you probably know about Phil Karlton's famous quote about the only two things that are difficult in computer science: cache invalidation and naming things. Since your needs are so generic, there is no easy answer. Moreover, I don't think there can be a correct answer as opinions may vary.

I will however give you my opinion:

I would call it fetchedData (or fetched_data, if that's what your programming language community prefers). The JSON or XML is just data and you fetched it so it seems like the most obvious to me.

I hope you don't spend too much time on this.

  • 1
    Deleted my answer as too similar to this one. The solution is changing fetch (confusing as a verb) to fetched. Adding Data or _data is more explanatory but not critical to the solution, imo.
    – GetzelR
    Jun 25, 2015 at 20:53

Try one of these:

  • Grab / Grabbed
  • Gather / Gathered
  • Collect / Collection
  • Store / Storage
  • Bring
  • Retrieved

Although I don't really see the advantage of only using one word. Don't be afraid to combine two words together in camel case (FetchedObject would actually work just fine).

  • For the object itself? The OP isn't looking for a new name for the action, but for the object that's "fetched".
    – Catija
    Jun 25, 2015 at 20:39
  • Sure, that's why I included the past tense forms of the action. I was trying to fit my possible answers within the confines of his requirement for it to be one word. Jun 25, 2015 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.