3

I am looking for a word that can describe the act of adding/removing objects but at the same time avoid a word that has to do with updating.

So, given

  1. adding an object,
  2. removing an object,
  3. updating an object,

I want a word for ((1 and 2) and not 3). So I guess words like alter won't do.

Edit: I am actually making an application, and I have three methods; adding, removing and updating. But there is some logic in both the adding and removing that is common. I then decided to make a fourth (helper) method. That's why I need this word so badly.

  • So you're asking whether there is a word that means both to add something and to remove it? A word that means its opposite? – Robusto May 1 '11 at 15:42
  • Yes. It may sound silly, but I was hoping there was a "common denominator". – whirlwin May 1 '11 at 15:43
  • 1
    Reconfigure, maybe? More context would help. – Callithumpian May 1 '11 at 16:14
  • @ Callithumpian: Done. – whirlwin May 1 '11 at 16:28
2

A class containing a collection of immutable objects might be a stack, where you push items in and pop them out. But if PushPop() doesn't do it for you, how about something like shift, with the implication that you can shift items onto or off of the stack.

|improve this answer|||||
1

If this is about method naming, then you really don't need a bona fide English word. You can construct your own hybrid. The obvious one that comes off the top of my head is

addOrRemoveObject()

but you should feel free to use whatever fits with your naming convention.

|improve this answer|||||
  • It's possible. However, I was hoping to avoid this approach. – whirlwin May 1 '11 at 16:41
1

What about to substitute?

According to the OALD, it means "to take the place of somebody/something else; to use somebody/something instead of somebody/something else".

Or also to replace, "to be used instead of something/somebody else; to do something instead of somebody/something else".

|improve this answer|||||
1

When you are adding, removing, and altering objects in a list, are you not "editing" that list?

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.