Marking plural of code words
In the language that I'm currently working in one of the keywords is
try. I'm writing an error message:
No implementation for global level try statements.
It's too long in my source and so I would very much like to reduce it to
No implementation for global level try's.
Anybody using my code should understand it very easily as my code is entirely about dynamically determining what exception handling is in place and the
try keyword is one of the cornerstones of exception handling in the given language.
- Could we pretend for the duration that I'm not being overly picky?
- Is this pluralization correct or at least acceptable? Both "tries" and "trys" look very wrong to me.
- Are there general rules pertaining to pluralizing keywords and other identifiers from programming languages. A quick google search and more extensive search of this site didn't quite do it. I did find this question. The selected answer assumes the presence of markup (not available in my case) and the other answer sidesteps the issue by avoiding pluralizing the words in question. Are there any new insights to be had?
An answer to (3) would answer (2) of course and so I would be happy with just that. If it's not available though, I would appeciate input on (2).