Technically, variable names don't need to be correct English usage in the first place. Good variable naming is about making it obvious to the programmer (and debugger, if they're different people) what the variable is supposed to do.
To that end, IntakenEnergy a fine variable name. (It might disagree with camelCase capitalization conventions, but that's another question.)
From the perspective of English, talking about "the grid" as a container of electrical energy is common usage. The energy that has been put into the grid could correctly be described, from the grid's perspective, as intaken energy.
I might have used a name like newEnergy, inputEnergy, or addedEnergy, but that's a matter of personal taste.